We would like to provide a final update regarding today's maintenance activity.
The infrastructure upgrade has been successfully completed for all US Production instances as well, and normal operations have fully resumed for both US and EU environments.
We understand that maintenance activities can be disruptive, and we sincerely appreciate your patience, understanding, and cooperation throughout this process. Our team remains committed to ensuring the reliability and stability of the platform while minimizing impact to your users.
Thank you for your continued partnership and support.
Best regards, Simpplr Team
Posted Jun 27, 2026 - 07:24 UTC
Update
Hello,
We are pleased to report that today's infrastructure upgrade has been successfully completed for all EU Production instances, and normal operations have fully resumed for these environments.
Maintenance activities are still underway for our US Production instances. We are monitoring the progress closely and will provide another update as soon as the remaining upgrades are complete.
Thank you for your patience and continued partnership. Simpplr Support Team
Posted Jun 27, 2026 - 06:24 UTC
Monitoring
Hi All,
To ensure the continued reliability, stability, and performance of the platform, we will be performing the infrastructure upgrade in our production environment. As part of this activity, we will be upgrading key platform components, including RDS in the Prod-EU and Prod-US environments and EKS cluster in the Prod-US environment. Expected Duration: Approximately 3 hours
During this maintenance window, the instance will remain available in read-only mode. Users will be able to access and view content; however, changes or updates to the platform will not be possible until the upgrade activity has been completed. We understand the impact this may have on your team's work and sincerely apologize for any inconvenience. Our team will be actively monitoring the activity and working to complete it as efficiently as possible.
We will continue to provide updates throughout the maintenance window and will notify you as soon as normal operations have been fully restored.
Thank you for your patience, understanding, and continued partnership while we perform this important platform maintenance. Simpplr Support Team
Posted Jun 27, 2026 - 04:32 UTC
This incident affected: EU (System) and US (System).